Trzepak.pl

Regulamin forum


Wypowiedzi muszą stosować się do zasad ogólnie przyjętej "netykiety" wynikającej z dokumentu RFC 1855, zamieszczonego pod tym adresem:
http://www.ietf.org/rfc/rfc1855.txt
Osoby wypowiadające się tu "zawodowo" proszone są o logowanie się swoim imieniem i nazwiskiem, a w stopce ich wypowiedzi wskazane jest przedstawienie danych adresowych łącznie z linkiem do strony głównej przedsiębiorstwa lub organizacji, którą reprezentują.
Umieszczanie informacji reklamowych w wypowiedzi i w stopce nie jest wskazane a moderatorzy mogą ingerować usuwając takie posty w sposób nie podlegający dyskusji.



Nowy temat  Odpowiedz w temacie
Autor Wiadomość
Post: ndz, 11 sie 2019 21:11:46 
   Tytuł: BIRD + OSPF Mikrotik
Odpowiedz z cytatem
Offline
Fanatyczny prenumerator
Fanatyczny prenumerator

Rejestracja: ndz, 12 gru 2004 21:57:48
Posty: 403
Lokalizacja: Z okolicy
Czy któryś z szanownych forumowiczów podzielił by się wiedzą tajemną jak skonfigurować ospf na Birdzie by zaczeło to wymieniać domyślną ścieżkę do natownicy na MT.
Obecna konfiguracja działająca na MT(bgp) <> MT(nat):
Kod:
/routing ospf instance
set [ find default=yes ] distribute-default=always-as-type-1 router-id=\
    192.168.50.2
/routing ospf network
add area=backbone disabled=yes
add area=backbone network=192.168.150.0/30
add area=backbone network=192.168.50.2/32

Na MT(nat)
Kod:
/routing ospf instance
set [ find default=yes ] name=R1 redistribute-connected=as-type-1 router-id=IP_zewn
add name=default router-id=192.168.50.1
/routing ospf interface
add interface=sfp-sfpplus1 network-type=broadcast

Między MT(bgp)<>MT(nat) ruch się przenosi. Po zmianie na Bird (ER-8-XG) i ustawieniu tam osfp niestety ruchu nie ma. Pomysłu też nie mam co jest źle.
Zmieniałem na iBGP i również ruchu 0 (prefixy przenosiły się do MT(nat)


Na górę
Post: ndz, 11 sie 2019 21:27:59 
Odpowiedz z cytatem
Offline
Fanatyczny prenumerator
Fanatyczny prenumerator

Rejestracja: śr, 04 cze 2014 16:36:16
Posty: 470
Bird rozprowadza to, co ma w jakimś protokole.
Czy bird zna trase 0/0? Jesli nie to jej nie rozgłosi :)
(nie czy kernel zna, czy bird zna)


Na górę
Post: ndz, 11 sie 2019 21:42:47 
Odpowiedz z cytatem
Offline
Fanatyczny prenumerator
Fanatyczny prenumerator

Rejestracja: ndz, 12 gru 2004 21:57:48
Posty: 403
Lokalizacja: Z okolicy
Było coś takiego
Kod:
protocol static static_ospf {
 import all;
 route 0.0.0.0/0 via IP_zewn;
}
protocol ospf {
#debug all;
import all;
export where proto = "static_ospf";

area 0.0.0.0 {
 
interface "eth8" {
            cost 10;
            type broadcast;
            };
           
                     };
}


Na górę
Post: wt, 13 sie 2019 12:59:02 
Odpowiedz z cytatem
Offline
Obsesyjny prozaik
Obsesyjny prozaik

Rejestracja: ndz, 27 lip 2014 13:37:16
Posty: 1036
https://www.bestpartner.pl/index.php?d=porada29


Na górę
Post: pn, 02 wrz 2019 15:24:04 
Odpowiedz z cytatem
Offline
Obsesyjny prozaik
Obsesyjny prozaik
Awatar użytkownika

Rejestracja: śr, 09 cze 2010 18:48:04
Posty: 1240
Lokalizacja: Suwałki
Ja to się tylko zastanawiam po co ospf w małych sieciach , jest prostsze rozwiązanie a i tak działa podobnie.

_________________
AS198408; BT2299-RIPE
IRCNET: #mikrotik.pl
URL: http://bgp4.pl
URL: http://emouse.pl


Na górę
Post: pn, 02 wrz 2019 18:44:28 
Odpowiedz z cytatem
Offline
Wyciszony literat
Wyciszony literat

Rejestracja: czw, 22 wrz 2011 12:00:12
Posty: 860
Method: co masz na myśli?
Nie można dać na natownicy default route przez maszynę z BIRDem a na maszynie z BIRDEM ustawić static route do podsieci będących za natownicą?

_________________
Rafał


Na górę
Post: wt, 03 wrz 2019 11:33:26 
Odpowiedz z cytatem
Offline
Obsesyjny prozaik
Obsesyjny prozaik
Awatar użytkownika

Rejestracja: śr, 09 cze 2010 18:48:04
Posty: 1240
Lokalizacja: Suwałki
cserf pisze:
Method: co masz na myśli?
Nie można dać na natownicy default route przez maszynę z BIRDem a na maszynie z BIRDEM ustawić static route do podsieci będących za natownicą?

Można ale to utrudnianie sobie życia. Jak lubisz non stop grzebać w birdc to spoko. Ja wyznaję zasadę , zrobić raz a dobrze i zapomnieć.

_________________
AS198408; BT2299-RIPE
IRCNET: #mikrotik.pl
URL: http://bgp4.pl
URL: http://emouse.pl


Na górę
Post: ndz, 08 wrz 2019 13:18:33 
Odpowiedz z cytatem
Offline
Fanatyczny prenumerator
Fanatyczny prenumerator

Rejestracja: ndz, 12 gru 2004 21:57:48
Posty: 403
Lokalizacja: Z okolicy
To może ktoś się podzieli działającym konfigiem dla Birda (epix + peer) + MT (nat)
Jak narazie trenowany ospf, ibgp i bird jak nie chciał dać ruchu na mt tak nie chce w żadnym przypadku.


Na górę
Post: ndz, 08 wrz 2019 15:41:05 
Odpowiedz z cytatem
Offline
Leniwy eseista
Leniwy eseista

Rejestracja: pn, 13 lip 2015 20:13:35
Posty: 504
https://netmon.pl/index.php/2018/10/08/ ... epix-bird/


Na górę
Post: ndz, 08 wrz 2019 22:07:15 
Odpowiedz z cytatem
Offline
Obsesyjny prozaik
Obsesyjny prozaik
Awatar użytkownika

Rejestracja: śr, 09 cze 2010 18:48:04
Posty: 1240
Lokalizacja: Suwałki
Co wam ludzie z tym birdem na łącze pewnie 1G albo mniej. Nie kumam.

_________________
AS198408; BT2299-RIPE
IRCNET: #mikrotik.pl
URL: http://bgp4.pl
URL: http://emouse.pl


Na górę
Post: ndz, 08 wrz 2019 22:41:47 
Odpowiedz z cytatem
Offline
Fanatyczny prenumerator
Fanatyczny prenumerator

Rejestracja: ndz, 12 gru 2004 21:57:48
Posty: 403
Lokalizacja: Z okolicy
Bardzo proste >> Na MT kończy się iface 1G na jednym z łącz. Naturalnym wyborem był Infinity ze swoimi 8xSFP+. Ponoć Bird taki zaje... już nie? :rotfl:


Na górę
Post: ndz, 08 wrz 2019 22:46:45 
Odpowiedz z cytatem
Offline
trzepakowy szaleniec
trzepakowy szaleniec

Rejestracja: wt, 06 lut 2007 13:29:28
Posty: 3694
Dzablo pisze:
Bardzo proste >> Na MT kończy się iface 1G na jednym z łącz. Naturalnym wyborem był Infinity ze swoimi 8xSFP+. Ponoć Bird taki zaje... już nie? :rotfl:


no lipa, już jest mikrotik 7 ;p

_________________
po godzinach... http://suzuki.a-ng.eu/forum/viewtopic.php?f=28&t=6570


Na górę
Post: ndz, 08 wrz 2019 22:46:45 
Odpowiedz z cytatem
Offline
trzepakowy szaleniec
trzepakowy szaleniec

Rejestracja: wt, 06 lut 2007 13:29:28
Posty: 3694
Dzablo pisze:
Bardzo proste >> Na MT kończy się iface 1G na jednym z łącz. Naturalnym wyborem był Infinity ze swoimi 8xSFP+. Ponoć Bird taki zaje... już nie? :rotfl:


no lipa, już jest mikrotik 7 ;p

_________________
po godzinach... http://suzuki.a-ng.eu/forum/viewtopic.php?f=28&t=6570


Na górę
Post: ndz, 08 wrz 2019 22:58:02 
Odpowiedz z cytatem
Offline
Fanatyczny prenumerator
Fanatyczny prenumerator

Rejestracja: ndz, 12 gru 2004 21:57:48
Posty: 403
Lokalizacja: Z okolicy
Beta? bo normalnej wersji na ich stronie nie widzę. Sorry ale dziękuję.


Na górę
Wyświetl posty nie starsze niż:  Sortuj wg  
Nowy temat  Odpowiedz w temacie


Kto jest online

Użytkownicy przeglądający to forum: MSN [Bot], Outlaw i 20 gości


Nie możesz tworzyć nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Przejdź do:  
Dzisiaj jest ndz, 15 gru 2019 0:17:20

Strefa czasowa UTC+02:00

Moderatorzy: Administratorzy, Moderatorzy

Nakarm glodne dziecko - wejdz na strone www.Pajacyk.pl


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
SubSilver2 modified for Trzepak.pl by Colir
Polski pakiet językowy dostarcza phpBB.pl