Trzepak.pl
https://trzepak.pl/

[MT] Site-to-site VPN (openvpn) znikajacy interfejs
https://trzepak.pl/viewtopic.php?f=26&t=58965
Strona 1 z 1

Autor:  Qmpeltaty [ czw, 07 cze 2018 0:28:37 ]
Tytuł:  [MT] Site-to-site VPN (openvpn) znikajacy interfejs

Mam spiete dwie lokalizacje openvpnem. Jeden MT1 ze stalym public IP robi za serwer, MT2 za neo ze zmiennym adresem IP laczy sie jako klient (potrzebuje dostepu do hostow za NATem na neo). Do tego mam zrobiony static route na MT1, ktory kieruje ruch do NAT za MT2 na interfejs, na ktorym spina sie MT2 z MT1.

Wszystko dziala do momentu zerwania polaczenia i zestawienia sie ponownie tunelu. Tworzy sie wtedy nowy interfejs i route jest unreachable, do czasu az nie wybiore ponownie "nowego" interfejsu (ktory defacto tak samo sie nazywa). Jak sobie z tym poradzic ?

Autor:  dasiu [ czw, 07 cze 2018 9:48:31 ]
Tytuł:  Re: [MT] Site-to-site VPN (openvpn) znikajacy interfejs

Na liście interfejsów dodajesz nowy interfejs "OVPN Server Binding" - nazywasz go jakoś i w polu "user" ustawiasz nazwę użytkownika z PPP Secrets który się łączy do OpenVPNa. Teraz zamiast interfejsu dynamicznego będziesz miał statyczny, który albo będzie "Running" albo nie (zależnie czy klient jest połączony).
Nie ma za co :).

Autor:  Qmpeltaty [ czw, 07 cze 2018 17:28:48 ]
Tytuł:  Re: [MT] Site-to-site VPN (openvpn) znikajacy interfejs

***, przetestuje i dam znac. :ok:

Autor:  Qmpeltaty [ czw, 07 cze 2018 23:02:59 ]
Tytuł:  Re: [MT] Site-to-site VPN (openvpn) znikajacy interfejs

Bangla !

*** EDIT ***

Jednak dalej nie bangla ;/ Pokazuje sie nowy interfejs co jakis czas i route przestaje dzialac.

Autor:  Qmpeltaty [ śr, 13 cze 2018 18:01:08 ]
Tytuł:  Re: [MT] Site-to-site VPN (openvpn) znikajacy interfejs

Qmpeltaty pisze:
Bangla !

*** EDIT ***

Jednak dalej nie bangla ;/ Pokazuje sie nowy interfejs co jakis czas i route przestaje dzialac.


Ktos pomoze ?

Strona 1 z 1 Strefa czasowa UTC+02:00
Powered by phpBB® Forum Software © phpBB Limited
https://www.phpbb.com/