Trzepak.pl


Nowy temat  Odpowiedz w temacie
Przejdź na stronę Poprzednia 1 2 3 4 5 Następna
Autor Wiadomość
Post: pn, 21 lis 2016 11:55:02 
Odpowiedz z cytatem
Offline
Żółtodziób
Żółtodziób

Rejestracja: ndz, 24 kwie 2016 17:20:31
Posty: 7
Witam
załączam konfiguracje RB751GL po FTTH. Gwoli wyjaśnienia zdefiniowałem 2 vlany: 100 i 101. Vlan 100 jest bez a 101 z TV. Różnią się one tym, że w vlan 101 pakiety multicast kierowane są do vlanu 839. Można oczywiście korzystać z internetu zarówno w vlan 100 jak i 101.
Kod:
[admin@MikroTik] > export
# sep/30/2016 18:52:34 by RouterOS 6.35.2
# software id = XXXX-XXXX
#
/interface bridge
add name=bridge-IPTV
/interface ethernet
set [ find default-name=ether3 ] master-port=ether2
set [ find default-name=ether4 ] master-port=ether2
set [ find default-name=ether5 ] master-port=ether2
/ip neighbor discovery
set ether1 discover=no
/interface vlan
add interface=ether1 name=vlan035 vlan-id=35
add interface=ether2 name=vlan100 vlan-id=100
add interface=ether2 name=vlan101 vlan-id=101
add interface=ether1 name=vlan839 vlan-id=839
/interface pppoe-client
add add-default-route=yes disabled=no interface=vlan035 name=pppoe-orange password=xxxxxxxx use-peer-dns=yes user=xxxxxxx@neostrada.pl
/interface ethernet switch port
set 0 vlan-header=add-if-missing vlan-mode=secure
set 1 default-vlan-id=100 vlan-header=always-strip vlan-mode=secure
set 2 default-vlan-id=100 vlan-header=always-strip vlan-mode=secure
set 3 default-vlan-id=100 vlan-header=always-strip vlan-mode=secure
set 4 default-vlan-id=101 vlan-header=always-strip vlan-mode=secure
set 5 vlan-mode=secure
/ip pool
add name=pool-100 ranges=192.168.100.10-192.168.100.99
add name=pool-101 ranges=192.168.101.10-192.168.101.99
/ip dhcp-server
add address-pool=pool-100 disabled=no interface=vlan100 name=server-100
add address-pool=pool-101 disabled=no interface=bridge-IPTV name=server-101
/interface bridge filter
add action=set-priority chain=forward in-interface=vlan101 new-priority=5 out-interface=vlan839 packet-type=multicast
add action=drop chain=forward out-interface=vlan839 packet-type=!multicast
add action=drop chain=output out-interface=vlan839 packet-type=!multicast
/interface bridge port
add bridge=bridge-IPTV interface=vlan101
add bridge=bridge-IPTV interface=vlan839
/interface ethernet switch vlan
add independent-learning=no ports=ether2,ether3,ether4,switch1-cpu switch=switch1 vlan-id=100
add independent-learning=no ports=ether5,switch1-cpu switch=switch1 vlan-id=101
add independent-learning=no ports=ether1,switch1-cpu switch=switch1 vlan-id=35
add independent-learning=no ports=ether1,switch1-cpu switch=switch1 vlan-id=839
/ip address
add address=192.168.100.254/24 interface=vlan100 network=192.168.100.0
add address=192.168.101.254/24 interface=vlan101 network=192.168.101.0
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=ether1
/ip dhcp-server network
add address=192.168.100.0/24 dns-server=192.168.100.254 gateway=192.168.100.254 netmask=24
add address=192.168.101.0/24 dns-server=192.168.101.254 gateway=192.168.101.254 netmask=24
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.100.254 name=router
/ip firewall filter
add chain=input comment="defconf: accept ICMP" protocol=icmp
add chain=input comment="defconf: accept established,related" connection-state=established,related
add action=drop chain=input comment="defconf: drop all from WAN" in-interface=pppoe-orange
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related
add chain=forward comment="defconf: accept established,related" connection-state=established,related
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface=\
    pppoe-orange
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" out-interface=pppoe-orange
/system clock
set time-zone-name=Europe/Warsaw
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=ether2
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=ether2
[admin@MikroTik] >


BTW jestem zawiedziony wydajnością routerów RB. Konfigurowałem Cloud Router CRS109 do pracy w sieci Orange FTTH. Maksymalnie udało mi się uzyskać transfer na poziomie 160 - 170Mb/s :\
Wydaje mi sie, ze powodem jest pppoe, bo NAT z Fast Trackiem powinien działać dużo szybciej.

pzdr.
j


Na górę
Post: wt, 22 lis 2016 21:36:36 
Odpowiedz z cytatem
Offline
Moderator
Moderator
Awatar użytkownika

Rejestracja: pt, 14 kwie 2006 5:31:19
Posty: 4370
Lokalizacja: woj Śląskie
janekk pisze:

BTW jestem zawiedziony wydajnością routerów RB. Konfigurowałem Cloud Router CRS109 do pracy w sieci Orange FTTH. Maksymalnie udało mi się uzyskać transfer na poziomie 160 - 170Mb/s :\
Wydaje mi sie, ze powodem jest pppoe, bo NAT z Fast Trackiem powinien działać dużo szybciej.

pzdr.
j


Bo CRS to jest switch nie router - chcesz miec wydajny router kup CCR

_________________
Jardo


Na górę
Post: czw, 24 lis 2016 14:50:04 
Odpowiedz z cytatem
Offline
Młodszy czytelnik
Młodszy czytelnik

Rejestracja: ndz, 06 paź 2013 21:30:03
Posty: 82
Udało mi się częściowo uruchomić telewizję na Mikrotiku niestety jest jeden minus.
Na porcie eth3 na którym działa TV śmiga też LAN, niestety nie mogę w żaden sposób zmusić do współpracy VOD.
Nie udało mi się uruchomić na dedykowanym porcie eth3 samej telewizji na Bridge o nazwie TV.
Dopiero wrzucenie wszystkich portów (vlan838,vlan839,ether3) do tego samego bridga LAN uruchamia TV.

Po włączeniu FastTracku i kilku podstawowych reguł Firewall udaje się osiągnąć pełną przepustowość łącza 600/60 Mbit.
Sprzęt mikrotik RB3011.

Dodatkowo jest to konfiguracja z zapasowym łączem do Internetu.
W momencie awarii internetu, ruch przełącza się na Internet Mobilny który mam podpięty do ether2.

Jak by ktoś miał pomysł jak uruchomić VOD dzielcie się configami :)

Kod:
# nov/24/2016 13:40:36 by RouterOS 6.37.1

/interface bridge
add name=LAN
add name=TV protocol-mode=none
/interface ethernet
set [ find default-name=ether1 ] arp=disabled comment=WAN mac-address=\
    00:00:00:00:00:DE name=WAN
set [ find default-name=ether2 ] comment="WAN 2 - PLAY"
set [ find default-name=ether3 ] comment=TV
set [ find default-name=ether5 ] comment=LAN
/ip neighbor discovery
set WAN comment=WAN
set ether2 comment="WAN 2 - PLAY"
set ether3 comment=TV
set ether5 comment=LAN
/interface vlan
add arp=disabled interface=WAN mtu=1492 name=vlan35 vlan-id=35
add arp=disabled interface=WAN loop-protect-disable-time=0s \
    loop-protect-send-interval=0s name=vlan838 vlan-id=838
add arp=disabled interface=WAN loop-protect-disable-time=0s \
    loop-protect-send-interval=0s name=vlan839 vlan-id=839
/interface pppoe-client
add add-default-route=yes disabled=no interface=vlan35 max-mru=1492 max-mtu=\
    1492 name=pppoe-orange password=PASS use-peer-dns=yes user=\
    USER@neostrada.pl
/ip pool
add name=LAN ranges=192.168.1.20-192.168.1.254
add name=VPN ranges=172.16.0.0/28
/ip dhcp-server
add address-pool=LAN disabled=no interface=LAN name=dhcp1
/interface bridge filter
add action=set-priority chain=forward in-interface=ether3 new-priority=5 \
    out-interface=vlan839 packet-type=multicast passthrough=yes
add action=drop chain=forward out-interface=vlan839 packet-type=!multicast
add action=drop chain=output out-interface=vlan839 packet-type=!multicast
add action=accept chain=forward in-interface=ether3 out-interface=vlan838 \
    packet-type=multicast
/interface bridge port
add bridge=LAN interface=ether4
add bridge=LAN interface=ether5
add bridge=LAN interface=ether6
add bridge=LAN interface=ether7
add bridge=LAN interface=ether8
add bridge=LAN interface=ether9
add bridge=LAN interface=ether10
add bridge=LAN interface=vlan839
add bridge=LAN interface=vlan838
add bridge=LAN interface=ether3
/ip address
add address=192.168.1.1/24 interface=LAN network=192.168.1.0
/ip dhcp-client
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no \
    interface=ether2
/ip dhcp-server network
add address=192.168.1.0/24 dns-server=192.168.1.1,8.8.8.8 gateway=192.168.1.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
/ip firewall filter
add chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment="defconf: accept established,related" \
    connection-state=established,related
add action=accept chain=input dst-port=80 protocol=tcp
add action=accept chain=input dst-port=1194 protocol=udp
add action=drop chain=input comment="defconf: drop all from WAN" \
    in-interface=pppoe-orange
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
add chain=forward comment="defconf: accept established,related" \
    connection-state=established,related
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=forward comment=\
    "defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface=pppoe-orange
/ip firewall nat
add chain=input comment="defconf: accept ICMP" protocol=icmp
add action=masquerade chain=srcnat
add action=dst-nat chain=dstnat comment="Przekierowania port\F3w do serwera" \
    dst-port=80 in-interface=pppoe-orange protocol=tcp to-addresses=\
    192.168.1.100 to-ports=80
add action=dst-nat chain=dstnat dst-port=1194 in-interface=pppoe-orange \
    protocol=udp to-addresses=192.168.1.100 to-ports=1194
/ip service
set telnet disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/lcd
set backlight-timeout=never default-screen=informative-slideshow
/lcd interface
add interface=pppoe-orange
/lcd interface pages
add interfaces=pppoe-orange
/system clock
set time-zone-name=Europe/Warsaw
/system routerboard settings
set protected-routerboot=disabled
/tool graphing interface
add interface=LAN
add interface=pppoe-orange



Na górę
Post: pt, 06 sty 2017 2:36:44 
Odpowiedz z cytatem
Offline
Żółtodziób
Żółtodziób

Rejestracja: pn, 02 kwie 2012 22:52:59
Posty: 21
Zaktualizowałem info dotyczące telefonii internetowej VOIP - dotyczy serwera proxy

_________________
"You can’t manage what you can’t measure"


Na górę
Post: ndz, 08 sty 2017 18:10:47 
Odpowiedz z cytatem
Offline
Żółtodziób
Żółtodziób

Rejestracja: ndz, 08 sty 2017 17:59:53
Posty: 2
Witam wszystkich,

Jestem tu nowy i szukam rozwiązania mojego probelmu który jest podobny. Posiadam Orange w technologi VDSL, do tego pakiet funpack oraz funbox 1.0. W podstawowej konfiguracji IPTV mogę oglądać na TV poprzez dekoder orange. Tutaj moje pytanie, czy mogę w jakiś sposób ogladać telewizje bezpośrednio podpinająć się do funbox'a ? IPTV jest w funbox'ie wypuszczone na jednym porcie (tam gdzie podłacza sie dekoder). Z góry dziekuję za pomoc i pozdrawiam.


Na górę
Post: pn, 09 sty 2017 0:26:56 
Odpowiedz z cytatem
Offline
Żółtodziób
Żółtodziób

Rejestracja: pn, 02 kwie 2012 22:52:59
Posty: 21
Strumień IPTV z Funboxa jest zaszyfrowany. A zatem może być zdekodowany przed dekoder wyposażony w odpowiednią kartę dostępu warunkowego, który dostarcza Orange.

_________________
"You can’t manage what you can’t measure"


Na górę
Post: pn, 09 sty 2017 11:18:24 
Odpowiedz z cytatem
Offline
Żółtodziób
Żółtodziób

Rejestracja: ndz, 08 sty 2017 17:59:53
Posty: 2
Dziękuję za odpowiedz.

Mam jeszcze pytanie odnoścnie IPTV, czy podłączając kable ethernet od IPTV oraz kabel od LAN do switch'a będę mógł korzystać z Internetu oraz IPTV po podłaczeniu się do switch'a trzecim kablem ethernet? Drugie pytanie to czy podłaczając kabel od IPTV oraz kabel od LAN do trójnika będę mógł korzystać z dwóch dobrodziejst od Orange po ponownym rodzileniu i podłaczeniu LAN do komputera, a IPTV do dekodera?


Na górę
Post: ndz, 15 sty 2017 15:31:47 
Odpowiedz z cytatem
Offline
Żółtodziób
Żółtodziób

Rejestracja: ndz, 15 sty 2017 15:29:39
Posty: 1
Mam pytanie do użytkujących Orange światłowód na własnym sprzęcie czy sesja pppoe jest automatycznie zrywana po upływie 22 lub 24 godzin ?


Na górę
Post: ndz, 15 sty 2017 16:58:23 
Odpowiedz z cytatem
Offline
Żółtodziób
Żółtodziób

Rejestracja: pn, 02 kwie 2012 22:52:59
Posty: 21
> Mam pytanie do użytkujących Orange światłowód na własnym sprzęcie czy sesja pppoe jest automatycznie zrywana po upływie 22 lub 24 godzin ?

tak

_________________
"You can’t manage what you can’t measure"


Na górę
Post: czw, 19 sty 2017 20:03:35 
Odpowiedz z cytatem
Offline
Żółtodziób
Żółtodziób

Rejestracja: czw, 19 sty 2017 19:40:35
Posty: 4
Witajcie, od wczoraj mam światłowód od Orange (300) i usilnie próbuję podłączyć internet do mojego domowego serwera (ubuntu 14.04) z pominięciem funboxa. Wypisz wymaluj, wariant IV z pierwszego posta. Problem jednak polega na tym, że mam wyłączenie internet, bez TV i telefonu, a niestety zalinkowane posty z micrology.pl całkowicie pomijają temat konfiguracji internetu opisując jedynie zmiany jakie trzeba wprowadzić aby dodać obsługę TV i telefonu. Przynajmniej tak ja to zrozumiałem.

Mogę prosić o wskazówki tudzież o namiary na jakiś post o konfiguracji samego dostępu do internetu? Próbowałem skonfigurować dostęp jak przez zwykłe pppoe ale nie chce zadziałać. :(


Na górę
Post: czw, 19 sty 2017 21:47:19 
Odpowiedz z cytatem
Offline
Żółtodziób
Żółtodziób

Rejestracja: pn, 02 kwie 2012 22:52:59
Posty: 21
https://help.ubuntu.com/community/Inter ... ionSharing
https://help.ubuntu.com/lts/serverguide/firewall.html
https://help.ubuntu.com/community/IptablesHowTo
https://help.ubuntu.com/community/Router
https://wiki.ubuntu.com/vlan

http://rsabalburo.blogspot.com/2015/02/ ... -1404.html
https://www.digitalocean.com/community/ ... untu-14-04

_________________
"You can’t manage what you can’t measure"


Na górę
Post: czw, 19 sty 2017 23:11:01 
Odpowiedz z cytatem
Offline
Żółtodziób
Żółtodziób

Rejestracja: czw, 19 sty 2017 19:40:35
Posty: 4
Szkoda, że jeszcze nie wkleiłeś linka jak linuksa zainstalować albo komputer włączyć bo to na pewno byłoby pomocne.

Takie linki to sobie sam umiem znaleźć. Gdyby działało, to bym tu nie pisał. Tak jak pisałem, próby uruchomienia pppoe kończą się time out'em.


Na górę
Post: pt, 20 sty 2017 0:35:31 
Odpowiedz z cytatem
Offline
Żółtodziób
Żółtodziób

Rejestracja: pn, 02 kwie 2012 22:52:59
Posty: 21
> Próbowałem skonfigurować dostęp jak przez zwykłe pppoe ale nie chce zadziałać.

Spróbuj skonfigurować RP-PPPoE zamiast domyślnego PPPoE i daj znać czy zadziała

_________________
"You can’t manage what you can’t measure"


Na górę
Post: pt, 20 sty 2017 18:10:10 
Odpowiedz z cytatem
Offline
Żółtodziób
Żółtodziób

Rejestracja: czw, 19 sty 2017 19:40:35
Posty: 4
Większość poradników i artykułów na ten temat jakie znalazłem traktowała od razu od rp-pppoe więc od tego zacząłem.

W logach mam tak:

Kod:
pppd 2.4.7 started by root, uid 0
Using interface ppp0
Connect: ppp0 <--> /dev/pts/1
CHAP authentication succeeded
CHAP authentication succeeded
LCP terminated by peer
Modem hangup
Connection terminated
Exit.


Zastanawia mnie skąd się wzięło to /dev/pts/1 skoro wszędzie w konfiguracji używam prawidłowej nazwy interfejsu (enp9s0). No chyba, że tak ma być. Wygląda na to, że połączenie doszło do skutku, nawet udało się zalogować, ale brakuje jakiejś pierdoły i ostatecznie nici z połączenia.


Na górę
Post: pt, 20 sty 2017 19:23:25 
Odpowiedz z cytatem
Offline
Żółtodziób
Żółtodziób

Rejestracja: pn, 02 kwie 2012 22:52:59
Posty: 21
Zestawiałem połączenie na Ubuntu 14.04 z wykorzystaniem rp-pppoe.

Obrazek


Kod:
#***********************************************************************
#
# pppoe.conf
#
# Configuration file for rp-pppoe.  Edit as appropriate and install in
# /etc/ppp/pppoe.conf
#
# NOTE: This file is used by the pppoe-start, pppoe-stop, pppoe-connect and
#       pppoe-status shell scripts.  It is *not* used in any way by the
#       "pppoe" executable.
#
# Copyright (C) 2000 Roaring Penguin Software Inc.
#
# This file may be distributed under the terms of the GNU General
# Public License.
#
# LIC: GPL
# $Id$
#***********************************************************************

# When you configure a variable, DO NOT leave spaces around the "=" sign.

# Ethernet card connected to DSL modem
ETH='vlan35'

# PPPoE user name.  You may have to supply "@provider.com"  Sympatico
# users in Canada do need to include "@sympatico.ca"
# Sympatico uses PAP authentication.  Make sure /etc/ppp/pap-secrets
# contains the right username/password combination.
# For Magma, use xxyyzz@magma.ca
USER='*******@neostrada.pl'

# Bring link up on demand?  Default is to leave link up all the time.
# If you want the link to come up on demand, set DEMAND to a number indicating
# the idle time after which the link is brought down.
DEMAND=no
#DEMAND=300

# DNS type: SERVER=obtain from server; SPECIFY=use DNS1 and DNS2;
# NOCHANGE=do not adjust.
DNSTYPE=SERVER

# Obtain DNS server addresses from the peer (recent versions of pppd only)
# In old config files, this used to be called USEPEERDNS.  Changed to
# PEERDNS for better Red Hat compatibility
PEERDNS=yes

DNS1=8.8.8.8
DNS2=8.8.4.4

# Make the PPPoE connection your default route.  Set to
# DEFAULTROUTE=no if you don't want this.
DEFAULTROUTE=yes

### ONLY TOUCH THE FOLLOWING SETTINGS IF YOU'RE AN EXPERT

# How long pppoe-start waits for a new PPP interface to appear before
# concluding something went wrong.  If you use 0, then pppoe-start
# exits immediately with a successful status and does not wait for the
# link to come up.  Time is in seconds.
#
# WARNING WARNING WARNING:
#
# If you are using rp-pppoe on a physically-inaccessible host, set
# CONNECT_TIMEOUT to 0.  This makes SURE that the machine keeps trying
# to connect forever after pppoe-start is called.  Otherwise, it will
# give out after CONNECT_TIMEOUT seconds and will not attempt to
# connect again, making it impossible to reach.
CONNECT_TIMEOUT=30

# How often in seconds pppoe-start polls to check if link is up
CONNECT_POLL=2

# Specific desired AC Name
ACNAME=

# Specific desired service name
SERVICENAME=

# Character to echo at each poll.  Use PING="" if you don't want
# anything echoed
PING="."

# File where the pppoe-connect script writes its process-ID.
# Three files are actually used:
#   $PIDFILE       contains PID of pppoe-connect script
#   $PIDFILE.pppoe contains PID of pppoe process
#   $PIDFILE.pppd  contains PID of pppd process
CF_BASE=`basename $CONFIG`
PIDFILE="/var/run/$CF_BASE-pppoe.pid"

# Do you want to use synchronous PPP?  "yes" or "no".  "yes" is much
# easier on CPU usage, but may not work for you.  It is safer to use
# "no", but you may want to experiment with "yes".  "yes" is generally
# safe on Linux machines with the n_hdlc line discipline; unsafe on others.
SYNCHRONOUS=no

# Do you want to clamp the MSS?  Here's how to decide:
# - If you have only a SINGLE computer connected to the DSL modem, choose
#   "no".
# - If you have a computer acting as a gateway for a LAN, choose "1412".
#   The setting of 1412 is safe for either setup, but uses slightly more
#   CPU power.
CLAMPMSS=1412
#CLAMPMSS=no

# LCP echo interval and failure count.
LCP_INTERVAL=20
LCP_FAILURE=3

# PPPOE_TIMEOUT should be about 4*LCP_INTERVAL
PPPOE_TIMEOUT=80

# Firewalling: One of NONE, STANDALONE or MASQUERADE
FIREWALL=NONE

# Linux kernel-mode plugin for pppd.  If you want to try the kernel-mode
# plugin, use LINUX_PLUGIN=/etc/ppp/plugins/rp-pppoe.so
LINUX_PLUGIN=

# Any extra arguments to pass to pppoe.  Normally, use a blank string
# like this:
PPPOE_EXTRA=""

# Rumour has it that "Citizen's Communications" with a 3Com
# HomeConnect DSL Modem DualLink requires these extra options:
# PPPOE_EXTRA="-f 3c12:3c13 -S ISP"

# Any extra arguments to pass to pppd.  Normally, use a blank string
# like this:
PPPD_EXTRA=""


########## DON'T CHANGE BELOW UNLESS YOU KNOW WHAT YOU ARE DOING
# If you wish to COMPLETELY overrride the pppd invocation:
# Example:
# OVERRIDE_PPPD_COMMAND="pppd call dsl"

# If you want pppoe-connect to exit when connection drops:
# RETRY_ON_FAILURE=no

_________________
"You can’t manage what you can’t measure"


Na górę
Post: czw, 26 sty 2017 17:53:24 
Odpowiedz z cytatem
Offline
Żółtodziób
Żółtodziób

Rejestracja: czw, 19 sty 2017 19:40:35
Posty: 4
Po wielu bojach udało mi się w końcu uruchomić łącze bez funboxa. Aczkolwiek, bez powyższej konfiguracji. Na testowym komputerze (klon serwera pod względem oprogramowania) połączenie zadziałało z konfiguracją od ubuntero ale nie udało mi się uruchomić tego przy starcie systemu lub po zerwaniu połączenia. Udało mi się natomiast to za pomocą narzędzia pppoeconf. Natomiast na właściwym serwerze, po użyciu pppoeconf cała sieć zdechła :sciana:. No ale, przywróciłem konfigurację z kopii i zrobiłem to samo, od nowa, ręcznie. I działa.

Obecnie mam w interfejsach tak:
Kod:
(...)
auto eth0.35
iface eth0.35 inet manual
        vlan_raw_device eth0
(...)
auto orange_ftth
iface orange_ftth inet ppp
pre-up /sbin/ifconfig eth0.35 up
provider orange_ftth   
       

i w pliku /etc/ppp/peers/orange_ftth
Kod:
noipdefault
defaultroute
replacedefaultroute

hide-password
lcp-echo-interval 20
lcp-echo-failure 3
connect /bin/true
noauth
persist
mtu 1492
noaccomp
default-asyncmap

plugin rp-pppoe.so eth0.35
user "******@neostrada.pl"


Użytkownik i hasło zapisani w chap- i pap-secrects i w zasadzie to tyle. Automatycznie łączy się przy starcie systemu, po zerwaniu połączenia również jest automatycznie zestawiane ponownie.

Speedtesty bez problemu osiągają 300Mbit/s, torrenty też śmigają jak trzeba, a obciążenie procesora w serwerze znikome.

Tylko jest jeden ból. Niech mi się wywali przeglądarka z powiedzmy 10 zakładami i po ponownym jej uruchomieniu wszystkie zaczną się ładować - dupa. Żadna się nie załaduje. I niektóre witryny są zupełnie nieosiągalne. Na przykład: http://40ton.net - na żadnym komputerze się nie załaduje. Bez znaczenia nawet przeglądarka. Nie i już. Nawet pinga puścić nie idzie. Dam sobie włosy na głowie ogolić, że pewnie to problem z konfiguracją. Kiedyś to rozpracuje :ok:


Na górę
Post: czw, 16 lut 2017 17:29:13 
Odpowiedz z cytatem
Offline
Żółtodziób
Żółtodziób

Rejestracja: czw, 16 lut 2017 15:04:17
Posty: 3
Witam serdecznie, po dwu-tygodniowych bojach, mogę nareście wskazać rozwiązanie na własny sprzęt zamiast routera od firmy Orange. Swoje rozwiązanie oparłem na routerze RouterEdge Lite 3 firmy Ubiquiti. Posiadam łącze światłowodowe 600/60 Mbps. Oto wynik testu na tym routerze.
Obrazek

Zastosowałem wariant II, z pewnymi zmianami. Posiłkowałem się przy tym forum francuskim, na którym znalazłem kilka ciekawych wątków nt. ustawień na routerze.
Przede wszystkim francuski Orange oferuje transmisje na poziomie ~1Gbps i do uzyskania połączenia z siecią używają protokołu DHCP zamiast PPPoE (MTU ustawione na 1500 zamiast 1492).
Router ERL 3, posiada trzy porty ETH z transmisją sięgającą do 3000 Mbps na firewall-u.
Port oznaczony:
ETH0 - podłączony do ONT
ETH1 - podłączony do modemu TV
ETH2 - podłączony do switcha LAN
Na eth0 ustawione trzy VLAN-y: 35, 838, 839
Na polskim Orange, połączyłem się na VLAN-ie 35 poprzez protokół PPPoE. Kolejny VLAN 838 służy do transmisji VOD/Replay na TV. Chciałem koniecznie pozbyć się routera od Orange, dlatego też ustawiłem klienta dhcp na tym właśnie VLAN-ie (838), odpowiednio ustawiając opcje:
60 - Vendor class identifier: sagemcom
77 - User Class Information: FSVDSL_funbox2.MLTV.softathome.Funbox2
i request: subnet-mask, rfc3442-classless-static-routes
Użycie RFC3442 do ustalania tras wymagało wrzucenia pliku rfc3442-classless-routes do systemowej partycji router-a w /etc/dhcp3/dhclient-exit-hooks.d/
Po restarcie, uzyskałem w ten sposób dodatkowy adres z puli 10.86.108.0/22 od Orange. Musiałem wymusić trasę routingu by domyślnie wychodziła na pppoe0, zamiast na adres 10.x.x.x
Obrazek

VLAN 839 to już transmisja multicastowa do modemu TV. Odpowiednio ustawiony ruch z eth0 (upstream) do eth1 (downstream), z pominięciem transmisji multicastu na eth2 (disable).
Na routerze działają dwie usługi DHCP, jedna z adresacją 192.168.1.0/24 na eth2 do sieci LAN, a druga z adresacją 192.168.2.0/24 na eth1 do TV. Modem TV otrzymuje zatem adres inny niż sieć lokalna.
Ustalone dwa wyjściowe NAT-y na pppoe0 oraz eth0.838, pozwoliły na komunikacje ze światem. DNS jest forwardowany z eth0 na pozostałe porty.
Dodatkowy przełącznik pozwolił mi na rozbudowanie sieci LAN, poprzez dodanie WiFi z UniFi AC Lite AP od firmy Ubiquiti i zasilanym poprzez gniazdko ethernet (POE) oraz telefonu VoIP z A510-IP.
Plik z konfiguracją wygląda tak:
Kod:
firewall {
    all-ping enable
    broadcast-ping disable
    ipv6-receive-redirects disable
    ipv6-src-route disable
    ip-src-route disable
    log-martians enable
    name WAN_IN {
        default-action drop
        description "WAN to internal"
        rule 10 {
            action accept
            description "Allow established/related"
            state {
                established enable
                related enable
            }
        }
        rule 20 {
            action drop
            description "Drop invalid state"
            state {
                invalid enable
            }
        }
    }
    name WAN_LOCAL {
        default-action drop
        description "WAN to router"
        rule 10 {
            action accept
            description "Allow established/related"
            state {
                established enable
                related enable
            }
        }
        rule 20 {
            action drop
            description "Drop invalid state"
            state {
                invalid enable
            }
        }
    }
    options {
        mss-clamp {
            interface-type pppoe
            interface-type pptp
            interface-type tun
            mss 1452
        }
    }
    receive-redirects disable
    send-redirects enable
    source-validation disable
    syn-cookies enable
}
interfaces {
    ethernet eth0 {
        description WAN
        duplex auto
        speed auto
        vif 35 {
            description "Internet ONT"
            egress-qos "0:0 1:1 2:2 3:3 4:4 5:5 6:6 7:7"
            pppoe 0 {
                default-route force
                firewall {
                    in {
                        name WAN_IN
                    }
                    local {
                        name WAN_LOCAL
                    }
                }
                mtu 1492
                name-server auto
                password <--- hasło --->
                user-id <--- login --->
            }
        }
        vif 838 {
            address dhcp
            description "VOD ONT"
            dhcp-options {
                client-option "send vendor-class-identifier &quot;sagemcom&quot;;"
                client-option "send dhcp-client-identifier 1:xx:xx:xx:xx:xx:xx;" <-- wstaw tutaj MAC adres routera od orange -->
                client-option "send user-class &quot;\047FSVDSL_funbox2.MLTV.softathome.Funbox2&quot;;"
                client-option "request subnet-mask, routers, rfc3442-classless-static-routes;"
                default-route update
                default-route-distance 210
                name-server update
            }
            egress-qos "0:4 1:4 2:4 3:4 4:4 5:4 6:4 7:4"
        }
        vif 839 {
            address 192.168.3.1/24
            description "TV ONT"
            egress-qos "0:5 1:5 2:5 3:5 4:5 5:5 6:5 7:5"
        }
    }
    ethernet eth1 {
        address 192.168.2.1/24
        description TV
        duplex auto
        speed auto
    }
    ethernet eth2 {
        address 192.168.1.1/24
        description LAN
        duplex auto
        speed auto
    }
    loopback lo {
    }
}
protocols {
    igmp-proxy {
        disable-quickleave
        interface eth0.839 {
            alt-subnet 0.0.0.0/0
            role upstream
            threshold 1
        }
        interface eth1 {
            alt-subnet 0.0.0.0/0
            role downstream
            threshold 1
        }
        interface eth2 {
            role disabled
            threshold 1
        }
    }
}
service {
    dhcp-server {
        disabled false
        hostfile-update disable
        shared-network-name FunBox {
            authoritative enable
            subnet 192.168.2.0/24 {
                default-router 192.168.2.1
                dns-server 192.168.2.1
                lease 86400
                start 192.168.2.30 {
                    stop 192.168.2.50
                }
            }
        }
        shared-network-name LAN {
            authoritative disable
            subnet 192.168.1.0/24 {
                default-router 192.168.1.1
                dns-server 192.168.1.1
                lease 86400
                start 192.168.1.38 {
                    stop 192.168.1.243
                }
            }
        }
        use-dnsmasq disable
    }
    dns {
        forwarding {
            cache-size 1000
            listen-on eth2
            listen-on eth1
        }
    }
    gui {
        http-port 80
        https-port 443
        older-ciphers enable
    }
    nat {
        rule 5010 {
            description "masquerade for WAN"
            log disable
            outbound-interface pppoe0
            protocol all
            type masquerade
        }
        rule 5011 {
            description "Masquerading Fanbox connections"
            log disable
            outbound-interface eth0.838
            protocol all
            type masquerade
        }
    }
    ssh {
        port 22
        protocol-version v2
    }
    upnp2 {
        listen-on eth1
        listen-on eth2
        nat-pmp enable
        secure-mode disable
        wan pppoe0
    }
}
system {
    conntrack {
        expect-table-size 4096
        hash-size 4096
        modules {
            sip {
                disable
            }
        }
        table-size 32768
        tcp {
            half-open-connections 512
            loose disable
            max-retrans 3
        }
    }
    host-name ubnt
    login {
        user ubnt {
            authentication {
                encrypted-password <--- zaszyfrowane hasło do routera --->
                plaintext-password ""
            }
            full-name ""
            level admin
        }
    }
    ntp {
        server 0.ubnt.pool.ntp.org {
        }
        server 1.ubnt.pool.ntp.org {
        }
        server 2.ubnt.pool.ntp.org {
        }
        server 3.ubnt.pool.ntp.org {
        }
    }
    offload {
        hwnat disable
        ipsec enable
        ipv4 {
            forwarding enable
            pppoe enable
            vlan enable
        }
        ipv6 {
            forwarding disable
        }
    }
    package {
        repository debian {
            components main
            distribution wheezy
            password ""
            url http://ftp.us.debian.org/debian
            username ""
        }
        repository wheezy {
            components "main contrib non-free"
            distribution wheezy
            password ""
            url http://http.us.debian.org/debian
            username ""
        }
    }
    syslog {
        global {
            facility all {
                level notice
            }
            facility protocols {
                level debug
            }
        }
    }
    time-zone Europe/Warsaw
    traffic-analysis {
        dpi enable
        export enable
    }
}


/* Warning: Do not remove the following line. */
/* === vyatta-config-version: "config-management@1:conntrack@1:cron@1:dhcp-relay@1:dhcp-server@4:firewall@5:ipsec@5:nat@3:qos@1:quagga@2:system@4:ubnt-pptp@1:ubnt-util@1:vrrp@1:webgui@1:webproxy@1:zone-policy@1" === */
/* Release version: v1.9.1.4939093.161214.0705 */

Hasło i login te od PPPoE.

Tak wygląda transmisja na routerze:
Obrazek


Na koniec moje spostrzeżenie:
Wypróbowałem również tańszy 5-portowy router EdgeRouter X SFP, który maksymalnie osiągał transmisje z internetu na poziomie ~400 Mbps. Niestety przeszkodą stał się procesor, który pracował na 100% i dalej nie pomógł. Konfiguracja z obu routerów jest podobna, poza jedną możliwością ustawienia szybkiej transmisji offload.

Mam nadzieję, że komuś w ten sposób pomogłem. Mi to zajęło 2 tygodnie, wypróbowując różnych konfiguracji codziennie po parę godzin. Z efektu jestem zadowolony :D


Na górę
Post: ndz, 19 lut 2017 0:55:13 
Odpowiedz z cytatem
Offline
Młodszy czytelnik
Młodszy czytelnik

Rejestracja: ndz, 06 paź 2013 21:30:03
Posty: 82
Muszę przyznać że konfiguracja demiurge, spowodowała że wyciągnąłem dekoder Orange z szuflady i rozpocząłem próby ułaskawienia TV na mikrotiku.
Niestety póki co przegrywam walkę z uruchamianiem VOD, ale znalazłem ciekawy wpis dotyczący konfiguracji mikrotika.

https://lafibre.info/remplacer-livebox/ ... -plus-plus

Patrząc wstecz na konfigurację Linuxa którą kiedyś przedstawiłem na micrology.pl, tam wydaje mi się że telewizja VOD działała bez żadnych wpisów autoryzujących i pobierających DHCP dla Vlan838.


Na górę
Post: ndz, 19 lut 2017 11:02:37 
Odpowiedz z cytatem
Offline
Żółtodziób
Żółtodziób

Rejestracja: czw, 16 lut 2017 15:04:17
Posty: 3
jagrok pisze:
...rozpocząłem próby ułaskawienia TV na mikrotiku.
Niestety póki co przegrywam walkę z uruchamianiem VOD, ale znalazłem ciekawy wpis dotyczący konfiguracji mikrotika.
https://lafibre.info/remplacer-livebox/ ... -plus-plus

Zgadzam się, że jest to jeden z bardziej kompleksowych wpisów, który można znaleźć w sieci w sprawie rozwiązania problemu zamiany routera Orange na własny sprzęt. Mi, osobiście, analiza tego rozwiązania przyniosła zrozumienie problemu.
Na tydzień przed ostatecznym rozwiązaniem, miałem przypięty router do ONT, a za nim router Orange, który przekazywał sygnał do dekodera TV. Ruch pomiędzy routerami był po dwóch Vlanach 838 i 839. Vlan 35 pozostawał na moim routerze.
Pomimo, że TV i częściowo VOD działał, nie dawało mi to spokoju, że muszę nadal używać dodatkowego sprzętu (router Orange).
jagrok pisze:
Patrząc wstecz na konfigurację Linuxa którą kiedyś przedstawiłem na micrology.pl, tam wydaje mi się że telewizja VOD działała bez żadnych wpisów autoryzujących i pobierających DHCP dla Vlan838.


Po włączeniu na swoim routerze RFC3442-classless-static-routes, zobaczyłem że ruch odbywa się po adresach 10/8 i multicast 232/8, stało się jasne, że router od Orange "coś miesza". Według wpisów na francuskim forum, uzyskiwali oni na Vlanie 838 dodatkowy adres z puli 10.x.x.x/21 wraz z odpowiednimi trasami routingu. To czego nie można było przenieść 1:1 od francuzów, to opcje do DHCP, które nie dawały odpowiedniego pobrania od polskich serwerów DHCP. Dlatego też podsłuchałem ruch pomiędzy dekoderem a routerem i uzyskałem odpowiednie informacje o ruchu DHCP.
Obrazek

Aktualna trasa routingu wygląda tak. Dwa ostatnie adresy uzyskałem z requesta "router" do DHCP na Vlanie 838 i przechodzą przez interfejs eth0.838.
Obrazek

Jeśli nie uzyskujesz adresu 10.x.x.x/22 na Vlanie 838, to sprawdź ruch pomiędzy dekoderem i routerem, aby wyłapać pakiet DHCP po restarcie(zresetowaniu) dekodera. Być może u Ciebie są inne opcje/ lub po prostu ich brakuje w ustawieniach Twojego sprzętu. W wpisie na francuskim forum, widnieje odpowiedni zapis dla Vlana 838 na Mikrotiku
Kod:
add code=60 name=class-identifier value="'sagem'"
add code=77 name=vod_userclass value=\
    "'+FSVDSL_livebox.MLTV.softathome.Livebox3'"
add code=61 name=clienId_livebox value=0x015eff56a2af15
...
/ip dhcp-client
add dhcp-options=class-identifier,clientId_livebox,hostname,vod_userclass \
    disabled=no interface=vlan838-vod

Powodzenia Ci życzę :ok:
P.S. Twój wpis na micrology.pl był dla mnie inspiracją do szukania rozwiązania na własnym sprzęcie :polacmu:


Na górę
Post: ndz, 19 lut 2017 21:26:45 
Odpowiedz z cytatem
Offline
Młodszy czytelnik
Młodszy czytelnik

Rejestracja: ndz, 06 paź 2013 21:30:03
Posty: 82
demiurge pisze:
Zgadzam się, że jest to jeden z bardziej kompleksowych wpisów, który można znaleźć w sieci w sprawie rozwiązania problemu zamiany routera Orange na własny sprzęt. Mi, osobiście, analiza tego rozwiązania przyniosła zrozumienie problemu.
Na tydzień przed ostatecznym rozwiązaniem, miałem przypięty router do ONT, a za nim router Orange, który przekazywał sygnał do dekodera TV. Ruch pomiędzy routerami był po dwóch Vlanach 838 i 839. Vlan 35 pozostawał na moim routerze.
Pomimo, że TV i częściowo VOD działał, nie dawało mi to spokoju, że muszę nadal używać dodatkowego sprzętu (router Orange).


To i tak poszedłeś dalej niż ja, ponieważ póki co nie mam pojęcia jak zrobić żeby net mieć na mikrotiku a sharować vlan35 :)

demiurge pisze:
Po włączeniu na swoim routerze RFC3442-classless-static-routes, zobaczyłem że ruch odbywa się po adresach 10/8 i multicast 232/8, stało się jasne, że router od Orange "coś miesza". Według wpisów na francuskim forum, uzyskiwali oni na Vlanie 838 dodatkowy adres z puli 10.x.x.x/21 wraz z odpowiednimi trasami routingu. To czego nie można było przenieść 1:1 od francuzów, to opcje do DHCP, które nie dawały odpowiedniego pobrania od polskich serwerów DHCP. Dlatego też podsłuchałem ruch pomiędzy dekoderem a routerem i uzyskałem odpowiednie informacje o ruchu DHCP.

Aktualna trasa routingu wygląda tak. Dwa ostatnie adresy uzyskałem z requesta "router" do DHCP na Vlanie 838 i przechodzą przez interfejs eth0.838.

Jeśli nie uzyskujesz adresu 10.x.x.x/22 na Vlanie 838, to sprawdź ruch pomiędzy dekoderem i routerem, aby wyłapać pakiet DHCP po restarcie(zresetowaniu) dekodera. Być może u Ciebie są inne opcje/ lub po prostu ich brakuje w ustawieniach Twojego sprzętu. W wpisie na francuskim forum, widnieje odpowiedni zapis dla Vlana 838 na Mikrotiku
Kod:
add code=60 name=class-identifier value="'sagem'"
add code=77 name=vod_userclass value=\
    "'+FSVDSL_livebox.MLTV.softathome.Livebox3'"
add code=61 name=clienId_livebox value=0x015eff56a2af15
...
/ip dhcp-client
add dhcp-options=class-identifier,clientId_livebox,hostname,vod_userclass \
    disabled=no interface=vlan838-vod




Podsłuchiwałeś będąc w sieci ichniejszego sprzętu/routera ?

demiurge pisze:
Powodzenia Ci życzę :ok:
P.S. Twój wpis na micrology.pl był dla mnie inspiracją do szukania rozwiązania na własnym sprzęcie :polacmu:


Dzięki, chyba byłem jedną z pierwszych osób które miały światłowód od Orange a że lubię kombinować poczyniłem takie kroki, by ludzie szukający tego typu rozwiązań, mogli działać :)
Przy okazji zastanawia mnie fakt czy polskie Orange nie planuje przejścia na autoryzację DHCP zamiast PPPOE, tak jak czyni to francuski dział Orange.


Na górę
Post: ndz, 19 lut 2017 22:35:13 
Odpowiedz z cytatem
Offline
Żółtodziób
Żółtodziób

Rejestracja: czw, 16 lut 2017 15:04:17
Posty: 3
jagrok pisze:
To i tak poszedłeś dalej niż ja, ponieważ póki co nie mam pojęcia jak zrobić żeby net mieć na mikrotiku a sharować vlan35 :)

Tak jak pisałem wcześniej, to aby dojść do pełnego rozwiązania, nawet z pomocą francuskiego forum, zajęło mi 2 tygodnie sprawdzania różnych configów i rozkminiania dlaczego to nie działa. Jeden wątek liczy ponad 2 lata, przez ten okres pojawiło się sporo rozwiązań.
Sharowanie vlanem35 widziałem u francuzów, ale stosujący do tego własny serwer DHCP z odpowiednim rfc3118-auth, który służy do autentykacji dla routera od Orange.
jagrok pisze:
Podsłuchiwałeś będąc w sieci ichniejszego sprzętu/routera ?

Aż tak to nie, ale zrobiłem mirror portu na switchu, który mi posłużył jako przejście vlanów do routera Orange. Stąd upewniłem się, że działa DHCP na vlanie 838 z odpowiednimi opcjami.
jagrok pisze:
Przy okazji zastanawia mnie fakt czy polskie Orange nie planuje przejścia na autoryzację DHCP zamiast PPPOE, tak jak czyni to francuski dział Orange.

Od niedawna, Orange wprowadziło nowe rozwiązanie router Funbox 3, które bezpośrednio ma wejście światłowodowe, z pominięciem ONT. Nie mam pojęcia czy już z DHCP zamiast PPPoE, czy też nadal pozostali przy rozwiązaniu poprzednim. Podejrzewam, że wprowadzą DHCP, gdyż łatwiej jest globalnie utrzymać ten sam model urządzeń i rozwiązań w tak globalnej firmie jak Orange. Oczywiście mówię o rozwiązaniach światłowodowych.


Na górę
Post: wt, 21 lut 2017 23:04:03 
Odpowiedz z cytatem
Offline
Subskrybent
Subskrybent

Rejestracja: pt, 30 lis 2007 18:28:45
Posty: 307
a ja dorzucę się do tematu z pytaniem - czy udało się komuś uruchomić supernovą w trybie ipv6 tj. uzytkownik@neostrada.pl/ipv6 na mikrotiku?

na mikrotiku mam ustawione:
Kod:
/interface pppoe-client
add add-default-route=yes default-route-distance=35 disabled=no interface=\
    vlan35 name=pppoe-out1 password=pass use-peer-dns=yes user=\
    user@neostrada.pl/ipv6
   
/ipv6 dhcp-client
add add-default-route=yes interface=pppoe-out1 request=address

jednak nie otrzymuję żadnego adresu
Kod:
[admin@rtr] /ipv6> dhcp-client print
Flags: D - dynamic, X - disabled, I - invalid
 #    INTERFACE                      STATUS        REQUEST                       
 0    pppoe-out1                     searching...  address     
 
 [admin@rtr] /interface pppoe-client> monitor 0
          status: connected
          uptime: 18m43s
    active-links: 1
        encoding:
    service-name:
         ac-name: byd_bng1_re0
          ac-mac: CC:E1:7F:05:CC:00
             mtu: 1480
             mru: 1480
   local-address: 0.0.0.0
  remote-address: 0.0.0.0


konfiguracja bez przyrostka /ipv6 działa bezproblemowo co potwierdza poprawną konfigurację vlanu35


Na górę
Post: śr, 22 lut 2017 1:15:51 
Odpowiedz z cytatem
Offline
Młodszy czytelnik
Młodszy czytelnik

Rejestracja: ndz, 06 paź 2013 21:30:03
Posty: 82
dfgg pisze:
a ja dorzucę się do tematu z pytaniem - czy udało się komuś uruchomić supernovą w trybie ipv6 tj. uzytkownik@neostrada.pl/ipv6 na mikrotiku?

na mikrotiku mam ustawione:
Kod:
/interface pppoe-client
add add-default-route=yes default-route-distance=35 disabled=no interface=\
    vlan35 name=pppoe-out1 password=pass use-peer-dns=yes user=\
    user@neostrada.pl/ipv6
   
/ipv6 dhcp-client
add add-default-route=yes interface=pppoe-out1 request=address

jednak nie otrzymuję żadnego adresu
Kod:
[admin@rtr] /ipv6> dhcp-client print
Flags: D - dynamic, X - disabled, I - invalid
 #    INTERFACE                      STATUS        REQUEST                       
 0    pppoe-out1                     searching...  address     
 
 [admin@rtr] /interface pppoe-client> monitor 0
          status: connected
          uptime: 18m43s
    active-links: 1
        encoding:
    service-name:
         ac-name: byd_bng1_re0
          ac-mac: CC:E1:7F:05:CC:00
             mtu: 1480
             mru: 1480
   local-address: 0.0.0.0
  remote-address: 0.0.0.0


konfiguracja bez przyrostka /ipv6 działa bezproblemowo co potwierdza poprawną konfigurację vlanu35

Walczyłem z tym tematem ale też mi się nie powiodło i nie próbowałem dalej, stwierdzając ze mam za mała wiedzę na ten temat.


Na górę
Post: śr, 22 lut 2017 1:19:40 
Odpowiedz z cytatem
Offline
Młodszy czytelnik
Młodszy czytelnik

Rejestracja: ndz, 06 paź 2013 21:30:03
Posty: 82
dfgg pisze:
a ja dorzucę się do tematu z pytaniem - czy udało się komuś uruchomić supernovą w trybie ipv6 tj. uzytkownik@neostrada.pl/ipv6 na mikrotiku?

na mikrotiku mam ustawione:
Kod:
/interface pppoe-client
add add-default-route=yes default-route-distance=35 disabled=no interface=\
    vlan35 name=pppoe-out1 password=pass use-peer-dns=yes user=\
    user@neostrada.pl/ipv6
   
/ipv6 dhcp-client
add add-default-route=yes interface=pppoe-out1 request=address

jednak nie otrzymuję żadnego adresu
Kod:
[admin@rtr] /ipv6> dhcp-client print
Flags: D - dynamic, X - disabled, I - invalid
 #    INTERFACE                      STATUS        REQUEST                       
 0    pppoe-out1                     searching...  address     
 
 [admin@rtr] /interface pppoe-client> monitor 0
          status: connected
          uptime: 18m43s
    active-links: 1
        encoding:
    service-name:
         ac-name: byd_bng1_re0
          ac-mac: CC:E1:7F:05:CC:00
             mtu: 1480
             mru: 1480
   local-address: 0.0.0.0
  remote-address: 0.0.0.0


konfiguracja bez przyrostka /ipv6 działa bezproblemowo co potwierdza poprawną konfigurację vlanu35


Ok problem mikrotika.
W obecnej wersji softu brak wsparcia opcji w dhcpv6 których wymaga Orange.
Planowane wsparcie od wersji RoterOs 7.

http://forum.mikrotik.com/viewtopic.php?t=104181


Na górę
Post: pn, 03 kwie 2017 12:42:13 
Odpowiedz z cytatem
Offline
Obserwator
Obserwator

Rejestracja: pt, 30 maja 2014 20:33:50
Posty: 25
Czy komuś udało się zastąpić Funbox 3.0 własnym routerem?

Jestem przed instalacją światłowodu od Orange ale już wiem że mam dostać Funbox 3.0 (podczas sporządzania umowy nie dało się zaznaczyć aby dostarczono mi ONT + Funbox 2) i teraz takie pytanie czy jeśli we własnym zakresie zakupie ONT dokładnie takie jak montuje Orange to czy będę mógł podłączyć go zamiast Funbox 3.0 czy lepiej pogadać z technikiem aby zamontował mi to ONT? Zamiast Funbox chciałbym nadal używać Mikrotika.


Na górę
Wyświetl posty nie starsze niż:  Sortuj wg  
Nowy temat  Odpowiedz w temacie
Przejdź na stronę Poprzednia 1 2 3 4 5 Następna


Kto jest online

Użytkownicy przeglądający to forum: Bing [Bot] i 1 gość


Nie możesz tworzyć nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Przejdź do:  
Dzisiaj jest śr, 28 cze 2017 4:02:42

Strefa czasowa UTC+02:00

Moderatorzy: Administratorzy, Moderatorzy

Nakarm glodne dziecko - wejdz na strone www.Pajacyk.pl


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
SubSilver2 modified for Trzepak.pl by Colir
Polski pakiet językowy dostarcza phpBB.pl