Trzepak.pl


Nowy temat  Odpowiedz w temacie
Autor Wiadomość
Post: pt, 10 lis 2017 9:22:22 
Odpowiedz z cytatem
Offline
Obserwator
Obserwator

Rejestracja: ndz, 14 lut 2016 19:26:59
Posty: 39
Witam wszystkich,

Sytuacja jest następująca:

Jest komp z WIN10. W terenie udostępniam mu połączenie typu hotspot z iPhone(iOS11). Po tym połączeniu loguję się po ssh etc. ale czasami potrzebuję dostępu do pewnej sieci w której na brzegu mam rb951 ze skonfigurowanym serwerem VPN L2TP. Jeśli używam hotspota z iPhone nie ma szans żeby się połączyć z tym VPN tzn. następuje próba łączenia, trwa weryfikacja danych i wisi wisi a później: nie można nawiązać połączenia.

Dalej:
- ten sam komp przy użyciu łącza od lokalnego ISP - prawidłowo zestawia się VPN, jest dostęp do sieci
- ten sam komp przy użyciu hotspot'a z innego telefonu(stareńki Samsung S4mini) - prawidłowo zestawia się VPN, jest dostęp do sieci
- na iPhone skonfigurowany klient L2TP - prawidłowo zestawia się VPN, jest dostęp do sieci

Wygląda na to, że jest jakiś problem podczas połączenia komputer <-> hotspot iPhone. Szukałem po necie ale nie znalazłem żadnego rozwiązania problemu. Czy ktoś ma coś takiego, może sprawdzić czy mu działa czy nie lub jak to naprawić po prostu? Ostatecznie będę po prostu musiał zakupić dodatkowy modem do kompa z internetem na kartę ale wolałbym tego nie robić.


Na górę
Post: pt, 10 lis 2017 10:55:39 
Odpowiedz z cytatem
Offline
Fanatyczny prenumerator
Fanatyczny prenumerator

Rejestracja: sob, 28 sie 2010 0:26:18
Posty: 404
Lokalizacja: Wrocław
W przypadku Plusa mialem takie jaja, jak uzywalem PPTP... Moze tu jest to samo?


Na górę
Post: pt, 10 lis 2017 11:09:27 
Odpowiedz z cytatem
Offline
Obserwator
Obserwator

Rejestracja: ndz, 14 lut 2016 19:26:59
Posty: 39
Obstawiam problem z telefonem(nieobsługiwanie czegoś/blokowanie) ponieważ ta sama karta(Orange) włożona do w/w Samsunga działa prawidłowo i nic podobnego się nie dzieje. Po prostu tak jakby połączenia VPN były blokowane gdy internet idzie przez hotspota iPhonowego.


Na górę
Post: pt, 10 lis 2017 12:49:10 
Odpowiedz z cytatem
Offline
Młodszy czytelnik
Młodszy czytelnik

Rejestracja: sob, 30 sty 2016 20:58:20
Posty: 75
Jaki firmware Mikrotika, do którego się łączysz?


Na górę
Post: pt, 10 lis 2017 13:13:48 
Odpowiedz z cytatem
Offline
Obserwator
Obserwator

Rejestracja: ndz, 14 lut 2016 19:26:59
Posty: 39
butchesky pisze:
Jaki firmware Mikrotika, do którego się łączysz?


6.40.4


Na górę
Post: pt, 10 lis 2017 20:04:43 
Odpowiedz z cytatem
Offline
Młodszy czytelnik
Młodszy czytelnik

Rejestracja: sob, 30 sty 2016 20:58:20
Posty: 75
Spróbuj połączyć się VPN z iPhone'a bezpośrednio z tym MT.
Jak zadziała - problem Win10.

Używam takiego połączenia często; działa bez pudła.

Zobacz też, co się dzieje w logu MTka.
I spróbuj wymusić na połączeniu vpn na MT l2tp (może jest auto).

Pptp nie zadziała na bank przez iPhone, przy którymś iOS odfiltrowali pptp.


Na górę
Post: wt, 14 lis 2017 11:45:47 
Odpowiedz z cytatem
Offline
Subskrybent
Subskrybent

Rejestracja: czw, 12 lut 2015 0:02:27
Posty: 399
Lokalizacja: Łódź
butchesky pisze:
Spróbuj połączyć się VPN z iPhone'a bezpośrednio z tym MT.
Jak zadziała - problem Win10.

Używam takiego połączenia często; działa bez pudła.

Zobacz też, co się dzieje w logu MTka.
I spróbuj wymusić na połączeniu vpn na MT l2tp (może jest auto).

Pptp nie zadziała na bank przez iPhone, przy którymś iOS odfiltrowali pptp.
Autor napisał ze takie połączenie mu działa.

Wysłane z mojego GT-S7580 przy użyciu Tapatalka


Na górę
Post: wt, 14 lis 2017 22:48:17 
Odpowiedz z cytatem
Offline
Młodszy czytelnik
Młodszy czytelnik

Rejestracja: sob, 30 sty 2016 20:58:20
Posty: 75
gavron: fakt, mój błąd; nie doczytałem.

Jednakże w logu przy tym wiszącym połączeniu nic się nie pojawia na MT?


Na górę
Post: wt, 11 wrz 2018 12:46:05 
Odpowiedz z cytatem
Offline
Obserwator
Obserwator

Rejestracja: ndz, 14 lut 2016 19:26:59
Posty: 39
Tak tylko dla potomnych bo problem "się rozwiązał"

Dokształciłem się nieco i okazało się, że IPsec b. nie lubi natów. Jak się okazało vpn był postawiony za 2 natami i jeszcze 3 NAT, który robił iPhone z hotspotem.

Rozwiązanie:
przerobienie adresu IP od ISP na tzw. real IP bez nata.

Efekt:
Wszystko działa doskonale, VPN się zestawia bez najmniejszego problemu dokladnie tak jak mi pasuje(używając hotspota iPhonowego).

Profit:
L2TP z IPsec wrogiem PPTP.


Na górę
Wyświetl posty nie starsze niż:  Sortuj wg  
Nowy temat  Odpowiedz w temacie


Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 4 gości


Nie możesz tworzyć nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Przejdź do:  
Dzisiaj jest śr, 19 wrz 2018 3:27:56

Strefa czasowa UTC+02:00

Moderatorzy: Administratorzy, Moderatorzy

Nakarm glodne dziecko - wejdz na strone www.Pajacyk.pl


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
SubSilver2 modified for Trzepak.pl by Colir
Polski pakiet językowy dostarcza phpBB.pl